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Spatial data is increasingly used
in agricultural production systems.
Cut sheets for field leveling, field
boundary layers for pesticide and
nutrient applications, levee files
for irrigation planning, and yield
maps from harvest equipment
are all examples of spatial data
essential to modern production
systems. The ability to handle,
visualize, modify, and share these
data requires specialized software
commonly referred to as geographic
information systems or GIS. Several
GIS software packages are available
with an assortment of capabilities,
industry scopes, and costs.

One well-developed and popular
open-source option that is not
industry specific is Quantum GIS,
or QGIS. QGIS is an official project
of the Open-Source Geospatial
Foundation (OSGeo) and is
continually updated and improved
by volunteer contributions to the
project (QGIS, 2023). QGIS is
compatible with Windows, macOS,
and Linux operating systems.

The objective of this document is
to provide an overview of QGIS
software installation, new project
creation, installation of plugins,
and basic instructions on spatial
data import.

Installing QGIS

The current version of QGIS
along with associated resources
and documentation can be found
at: https://www.qgis.org/en/site
index.html. Click the
button, select either the available
“Long Term Version” or “Latest
Version” recommended for your
system. Alternatively, select one
of the drop-down menus for other
operating systems. The “Latest”
version includes all recent QGIS

functionalities additions, but

some unresolved issues may create
glitches that affect software
utilization. The "Long Term
Version” does not include the

most recent QGIS functionality
additions, but most issues and
glitches were resolved by OSGeo to
maximize user experience. Open the
Downloads folder and double click
the downloaded QGIS-OSGeoW4-
xxx file once to begin installation.
Note that it may take a few minutes
to complete the executable file
download as this is dependent on
internet speed. Follow the prompts
in the pop-up window to install the
program. Once installed, open the
QGIS software by double clicking on
the new desktop icon. This will open
the QGIS interface with an untitled
QGIS Project.
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Creating a New Project

Upon opening QGIS, a user
interface like Figure 1 will appear.
Across the top of the user interface
are three toolbars surrounded by
the purple box [[] (Figure 1). The
uppermost tool bar is called the
Menu toolbar. Below the Menu
toolbar is the Attributes toolbar,
and below the Attributes toolbar,
is the Vector toolbar. If you hover
over a blank portion of any of these
toolbars, each respective name will
appear next to the cursor. Likewise,
if you hover over any of the buttons
in the Attribute or Vector toolbars,
the name or action of that button
will appear. Some of the more
commonly used navigation buttons
on the Attributes tab and their
hover descriptions are shown in
Figure 3. In this initial interface,
there is also a “Recent Projects”
window represented by the green
box | |in Figure 1 that may be
empty but will populate projects as
they are created. D

Upon initial startup, inside
the “Project Templates” window
represented by a red box D in
Figure 1, there is the option to
create “New Empty Project”. Once
a new project is created, data layers
can be added. Alternatively, begin
a new project by navigating to the Menu toolbar
and click the “Projects” button and then “New”
to create a new project. By default, QGIS will
name this “Untitled Project”. To properly name
a project, navigate to the Menu toolbar again
and click on “Project” and “Save As” to save the
new QGIS project on a computer drive. Navigate
through the folders and choose where to save the
new QGIS project. Provide a file name and click on
“Save”.

Getting to know the QGIS interface

In addition to the three toolbars mentioned
above, the browser window highlighted with
the blue box [} in Figure 1 is where the

Figure 1. QGIS user interface upon startup includes the Menu, Attribute, and Vector toolbars
across the top, and the Browser, Layers, Recent Projects and Project Templates windows.

Figure 2. QGIS project opened with the Search QMS window displayed, and Bing Aerial raster
layer with vector files representing field boundaries and water source locations imported.

Figure 3. Common map navigation options
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software allows the user to find and load files
from a computer into an open project. Only

QGIS recognized file types and resources will be
displayed in this window, and they can be dragged
and dropped into the Layers window represented
by the yellow box = if a project is open. Once
layers are added to the Layers window, they will
be displayed in the map interface (provided the
“Display” box is checked for the respective layer).
Alternatively, layers from the Browser window



can be dragged and directly dropped into the

map interface. Figure 2 shows the user interface
with an open project. Notice that layers are both
populated in the Layers window and displayed

in the map interface. In the next section, adding
background maps, raster layers, and vector layers
to a blank interface will be discussed.

Community-Built Plugins

One standout feature of QGIS is its extensive
ecosystem of community-built plugins, which
allows users to tailor the software to specific
needs. These plugins are developed by contributors
worldwide and undergo a rigorous review
process to ensure functionality, security, and
compatibility with the latest QGIS versions. Once
approved, they are hosted in the official QGIS
Plugin Repository at https://plugins.qgis.org/,
where over 1,000 options are available for free

download.

Plugins extend QGIS’s core capabilities by
adding specialized tools, processing algorithms,
data connectors, or visualization enhancements—
such as QuickMapServices for easy basemap
integration or Processing Toolbox extensions
for advanced geospatial analysis. Core plugins
(bundled with QGIS) handle essential functions
like georeferencing, while external plugins (mostly
Python-based) offer customization options.

To download and install plugins, simply
launch the built-in Plugin Manager: Go to Plugins
> Manage and Install Plugins from the top
menu. In the dialog, use the All tab to browse or
search by keyword, then select a plugin to view
its details (including ratings, descriptions, and
compatibility). Click Install to fetch the latest
stable version directly from the repository.
QGIS handles the download and activation
automatically. Experimental or deprecated
plugins can be enabled via settings if needed.
Installed plugins appear in the Installed tab for
easy enabling/disabling, and QGIS can check for
updates on startup, daily, or weekly to keep the
toolkit current.

Adding Background Maps

Background maps provide context for a
project, assist with orienting the data layers, and

often act as a canvas for annotating other features.
Example background maps are simple highway
maps with state or county boundaries and imagery
layers such as Google or Bing Maps. These maps
can be imported to a project in different ways.
OpenStreetMap is an open-source background
highway map that is installed by default with
QGIS.

To display OpenStreetMap:

In the “Browser” window, click the > to
expand the “XYZ Tiles” option.

Double click OpenStreetMap to add it to the
map window (also note that it has been added
to the “Layers” window.

A global map may be displayed; use the mouse
scroll wheel to zoom to the project’s area of
interest. Use the navigation options (Figure
3) on the Attribute toolbar to navigate in the
mapping interface.

Often, more detail in a background map is
necessary. As an example, the boundaries of
an agricultural field may be helpful; however,
this level of detail is simply not included in
OpenStreetMap. Imagery layers from satellite
are great when this level of detail is required;
however, they take a few extra steps to be
displayed in QGIS. These imagery layers require
the installation of a plugin, as mentioned
above, from imagery providers. In this case, the
installation of the plugin “QuickMapServices” will
provide access to an open-source background layer
for map context.

To install QMS plugin and display open-source
background imagery:

On the “Menu” toolbar select “Plugins”, then
“Manage and Install Plugins...”

On the left-hand side of the “Plugins”
window, select the “All” tab and search
“QuickMapServices”.

Select “QuickMapServices” in the results
window, and press “Install Plugin”, then
“Close”.

On the “Menu” toolbar, select “Web” then
“QuickMapServices, and then “Search
NextGIS QMS” .


https://plugins.qgis.org/

A “Search NextGIS QMS” window appears on
the right side of the screen, type “Bing”.

Next to “Bing Maps Satellite Imagery”, select
“Add”.

A satellite imagery layer should be displayed,
and a new “Bing Maps” layer should appear
in the “Layers” window. If imagery does not
appear, make sure it is not behind another
layer by unchecking anything above it in the
“Layers” window.

In future project sessions, the QMS Search
window may not appear by default and must be
reopened.

To reopen the QMS Search window:

Navigate to the “Vector Toolbar” and select

the “Search QMS” button again.

The “Search QMS” window will reappear on
the right side of the screen.

Adding imagery (raster layers)

A raster is a layer of continuous cells
representing an image or often a continuous
phenomenon. Examples of raster layers include
aerial imagery such as drone or satellite collected
images, and modeled data including digital
elevation models and vegetative indices.

To add a raster layer to the QGIS project:

Navigate to the Menu toolbar and click
“Layer” > “Add Layer” > “Add Raster Layer”.

”»

In the “Source” search bar click “...

Navigate to the imagery layer, select “Open”
and then “Add”.

Or simply drag the file from file explorer to the
map area.

Importing vector layers

Vector layers represent points, lines, or
polygons such as the locations of wells, levees,
and field boundaries, respectively. Vector files
can be exported from field machinery, downloaded
from online databases, and shared from mobile
devices. More information can be found on spatial
data types in the University of Arkansas System
Division of Agriculture Factsheet 2216 found at
https://www.uaex.uada.edu/publications/pdf

FSA2216.pdf. When importing and using vector
layers, it is also important to consider Coordinate
Reference Systems (CRS). CRSs defines how
spatial data coordinates relate to real-world
locations, enabling accurate mapping and analysis
in QGIS. QGIS will attempt and often succeed

at detecting a layer’s CRS upon importing it.

It is possible to import a layer with a different
CRS than that of the current project. QGIS will
attempt to “reproject” the imported layer “on-the-
fly”. In this case, the layer’s CRS will be retained,
but it will be projected using the project CRS and
displayed in the correct location. If a layers CRS
is not defined, not found by QGIS or, on-the-fly
reprojection fails, a warning appears, and users
are directed to select or transform the layers CRS
to align datasets, ensuring proper geographic
representation and calculations.

To import vector files into a QGIS Project:

Navigate to the Menu toolbar and click
“Layer” > “Add Layer”

Notice all the different layer types that can
be added along the left side of the Add Layer
window.

Make sure that the “Vector Layer” tab is
selected

”»

In the “Source” search bar, click “...”.
Navigate to the desired import.

Click “Add”. The new layer should now
appear in the “Layers” window and in the map
window.

Or simply drag the file from file explorer to the
map area.

Adjusting layer display order

While working on a project, it may be
necessary to adjust how a layer is displayed.
Layers are overlayed on the map in the same
order they are displayed in the Layers window.
Therefore, one layer may hide another one below.
To move the hidden layer forward, change the
display order in the Layers window.

To change the display order or layers:

Navigate to the Layers window, left click, and
hold the layer that needs to be moved.

While holding, drag and drop the layer to the
desired location.
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« Alternatively, layers can be unchecked in the
Layers window to make other layers visible.

Conclusion

QGIS is a powerful open-source mapping
software that allows for the viewing and
manipulation of spatial data including vector
and raster layers. Agriculture systems are
increasingly generating and utilizing spatial
data for production decisions, field operations
planning, and input management. QGIS can be
used to organize and manage these data sets. This
publication has discussed the installation of QGIS,
starting a new project, displaying background
maps, adding vector layers (points, lines, and
polygons), and adjusting how these layers are
organized to facilitate visualization analysis.
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